Degraded Application Performance
Resolved
Jul 17 at 01:05am EDT
On Tuesday July 16th around 8:45PM to 1AM EST, a trivia game was ran in an edge-case configuration that caused one of Crowdpurr’s micro-services, our sync server that is responsible for updating Participant Views and Presentation Views with host actions triggered on the Experience Dashboard, to overload and become slow and unresponsive.
A fairly recent change to our codebase caused an unanticipated load on the microservice which normally and historically has never overloaded and has always been run with minimal resources.
We have updated the microservice with twice the processing power, six times the memory, and ten times the throughput allowance. This will resolve the issue moving forward. Please accept our sincere apologies for your disrupted events and frustration experienced. We strive to deliver a smooth experience that can always be relied upon 100% of the time. As we know your live events depend on it.
Affected services
Experience Dashboard & Presentation View
Participant View
API & Rankings
Created
Jul 16 at 08:45pm EDT
Currently the Participant View is updating very slowly or not at all when actions are triggered on the Experience Dashboard.
Our team is investigating the issue.
Affected services
Experience Dashboard & Presentation View
Participant View
API & Rankings