Crowdpurr Ingress is experiencing an outage
Resolved
Mar 01 at 11:15am EST
The Crowdpurr Ingress server has been restored. Our team quickly responded to the outage and restored the service within seven minutes.
This is yet another unusual outage for Crowdpurr's Ingress server which is the load balancer that spreads out all joining participants across our various Participant View application servers. Crowdpurr's application servers did not experience an issue.
Our team is currently reviewing the incident. We have traced it to a software bug in a third party web server software that we use in our stack. It is not a Crowdpurr software issue. Our team is checking with the third party to see if they are aware of the issue.
Our team has already updated the load balancer machine with a configuration that will automatically restart the machine if this issue happens again, thus drastically reducing any downtime.
Lastly, after several issues with this particular service, we are reviewing the option of replacing it with with a more well-known industry standard web server software.
While no incident involving downtime is acceptable, we are pleased that the service was only down for seven minutes compared to the previous incident.
Affected services
Crowdpurr Ingress
Created
Mar 01 at 11:04am EST
The Crowdpurr Ingress server is currently experiencing an outage. Our team was notified and are currently diagnosing the issue.
Affected services
Crowdpurr Ingress